snipt

Ctrl+h for KB shortcuts

Text only

ADMIN TOOLS TROUBLESHOOTING STEPS

Let's make sure that the problem is indeed caused by Admin Tools. In order to do so, try the following:

1. Try setting the Error Reporting level in your Global Configuration to "None". Many errors are caused by harmless PHP Notices and Warnings being output to the browser, breaking anything which requires HTTP header manipulation such as Joomla!'s session management, AJAX calls and download systems.

2. Try to replicate the issue after disabling the "System - Admin Tools" plugin. If you can still replicate the issue, it is not caused by Admin Tools. Disabling that plugin means that Admin Tools code (including the Web Application Firewall) is not running on your site.

3. If you suspect an issue with the .htaccess file, replace its contents with the contents of the stock htaccess.txt file shipped with every version of Joomla!. If you are on GoDaddy please wait for 1-30 minutes for the changes to be effective. Then, retry loading the problem page. If you can still reproduce the error, then it is not caused by .htaccess Maker.

If doing any of the above resulted in the issue still occurring, it's not related with Admin Tools and I can't help you. If doing any of the above did stop the issue from occurring, we'll have to do some troubleshooting.

First go to Admin Tools, Web Application Firewall, Configure WAF. Make sure "Log security exceptions" is set to Yes; if it's not, set it to Yes and click on Save. Now try reproducing your issue. Immediately after that, please go to Admin Tools, Web Application Firewall, Security Exceptions Log and go to the last page. The last log entry should have the date and time of when the issue occurred. Please copy the Reason and Target URL here so that I can help you.

If, however, you do not see a log entry, or the Date and/or IP address do not match your last access, this problem is not caused by Admin Tools' WAF. In this case, you will have to do some .htaccess troubleshooting. You may need to read the [url=https://www.akeebabackup.com/documentation/troubleshooter/athtaccess500.html]general .htaccess troubleshooting page[/url], as well as the [url=https://www.akeebabackup.com/documentation/troubleshooter/athtaccessexceptions.html]page on finding out necessary .htaccess exceptions[/url].
https://snippets.siftie.com/embed/67500ab8a3d0d54ca2b9250bee984404/
/raw/67500ab8a3d0d54ca2b9250bee984404/
67500ab8a3d0d54ca2b9250bee984404
text
Text only
13
2019-04-20T16:24:10
True
False
False
/api/public/snipt/55296/
admin-tools-troubleshooting-steps
<table class="highlighttable"><tr><td class="linenos"><div class="linenodiv"><pre><a href="#L-1"> 1</a> <a href="#L-2"> 2</a> <a href="#L-3"> 3</a> <a href="#L-4"> 4</a> <a href="#L-5"> 5</a> <a href="#L-6"> 6</a> <a href="#L-7"> 7</a> <a href="#L-8"> 8</a> <a href="#L-9"> 9</a> <a href="#L-10">10</a> <a href="#L-11">11</a> <a href="#L-12">12</a> <a href="#L-13">13</a></pre></div></td><td class="code"><div class="highlight"><pre><span></span><span id="L-1"><a name="L-1"></a>Let&#39;s make sure that the problem is indeed caused by Admin Tools. In order to do so, try the following: </span><span id="L-2"><a name="L-2"></a> </span><span id="L-3"><a name="L-3"></a>1. Try setting the Error Reporting level in your Global Configuration to &quot;None&quot;. Many errors are caused by harmless PHP Notices and Warnings being output to the browser, breaking anything which requires HTTP header manipulation such as Joomla!&#39;s session management, AJAX calls and download systems. </span><span id="L-4"><a name="L-4"></a> </span><span id="L-5"><a name="L-5"></a>2. Try to replicate the issue after disabling the &quot;System - Admin Tools&quot; plugin. If you can still replicate the issue, it is not caused by Admin Tools. Disabling that plugin means that Admin Tools code (including the Web Application Firewall) is not running on your site. </span><span id="L-6"><a name="L-6"></a> </span><span id="L-7"><a name="L-7"></a>3. If you suspect an issue with the .htaccess file, replace its contents with the contents of the stock htaccess.txt file shipped with every version of Joomla!. If you are on GoDaddy please wait for 1-30 minutes for the changes to be effective. Then, retry loading the problem page. If you can still reproduce the error, then it is not caused by .htaccess Maker. </span><span id="L-8"><a name="L-8"></a> </span><span id="L-9"><a name="L-9"></a>If doing any of the above resulted in the issue still occurring, it&#39;s not related with Admin Tools and I can&#39;t help you. If doing any of the above did stop the issue from occurring, we&#39;ll have to do some troubleshooting. </span><span id="L-10"><a name="L-10"></a> </span><span id="L-11"><a name="L-11"></a>First go to Admin Tools, Web Application Firewall, Configure WAF. Make sure &quot;Log security exceptions&quot; is set to Yes; if it&#39;s not, set it to Yes and click on Save. Now try reproducing your issue. Immediately after that, please go to Admin Tools, Web Application Firewall, Security Exceptions Log and go to the last page. The last log entry should have the date and time of when the issue occurred. Please copy the Reason and Target URL here so that I can help you. </span><span id="L-12"><a name="L-12"></a> </span><span id="L-13"><a name="L-13"></a>If, however, you do not see a log entry, or the Date and/or IP address do not match your last access, this problem is not caused by Admin Tools&#39; WAF. In this case, you will have to do some .htaccess troubleshooting. You may need to read the [url=https://www.akeebabackup.com/documentation/troubleshooter/athtaccess500.html]general .htaccess troubleshooting page[/url], as well as the [url=https://www.akeebabackup.com/documentation/troubleshooter/athtaccessexceptions.html]page on finding out necessary .htaccess exceptions[/url]. </span></pre></div> </td></tr></table>